かすてらすねお。(hateblo)

見聞録的ななにか。

EclipseでScalaプラグインが使えない問題について

エラーと原因

 このたびPlay!Frameworkを使うための環境を整えようと、Eclipse Juno (4.2)にScalaプラグインをインストールしたところ 、

class file needed by BodyParser is missing.
reference type Either of object package refers to nonexisting symbol.

 というエラーが出てしまいまして、要するに「キミの入れたScalaプラグインのバージョン古いよ」と怒られて困りました。

解決方法と注意

 これについてググってみたところ、StackOverFlowにどストライクな質問と回答が存在していました。(Play Framework 2.1: BodyParser class file missing)こちらの回答によれば、ScalaIDE FOR ECLIPSEの公式サイト見ろとのことでして、サ イトの中を注意深く探しますと、EclipseのバージョンごとにインストールすべきプラグインのURLがきちんと掲載されています。 (Download the 3.0 Release of the Scala IDE for Eclipse)。 こちらの中から自分のEclipseに該当するかどうか注意してアドレスを選んで、Eclipseの新規ソフトウェアのインストー ルのURL入力欄に突っ込めば、後は通常のプラグインインストール操作と変わりません。

以上